[Insight-developers] itkPoint itkVector additional methods
Luis Ibanez
ibanez@choroid.cs.unc.edu
Mon, 23 Jul 2001 14:38:16 -0400 (EDT)
Jim,
1) Ok for renaming SetToMedian() to SetToMidpoint()
(of maybe SetToMidPoint() ?)
"Median" is a correct geometrical term, but I
agree with SetToMidPoint() as the most intuitive
name.
2) About the static classes, that's also a good option,
but for something really fast as the SetToMidPoint(),
the call:
Point q = MidPoint( a, b);
implies an overhead of calling twice the contructor
of itkPoint, for dealing with the temp variable on
return. Any way, nothing prevent us from providing
both methods, with the corresponding warning on the
documentation.
3) LinearCombination() is also a more intuitive name.
though "Barycentric combination" is the official
technical name. I'll move the "Barycentric" text
to the doxygen header, it has now some LaTeX
equations, and rename the method as LinearCombination().
4) I like the option of the more generic method that
receive an array of points,.. I was just wandering
what this array should be :
- a C array of Point
- an STL container of Points
- an ITK container of Points
- an ITK PointSet
Any suggestions ?
Luis