Naming conventions

Josh Cates cates at rolle.engr.utk.edu
Tue Apr 18 11:37:00 EDT 2000


Some comments regarding naming conventions:

1) Does using the STL naming convention give the user the (false)
impression that our toolkit fully supports the STL generic programming
model?  If so, maybe it is good to distinguish our objects from STL
objects.

2) As Luis pointed out, adopting the STL convention requires adopting the
use of namespaces.  Not a bad idea in my opinion to use namespaces, but it
does raise some additional issues over just changing naming conventions
(compiler support, etc).

Josh.

+--+--+--+--+--+--+--+--+--+--+--+--
 Josh Cates			
 Dept. of Electrical Engineering	
 University of Tennessee, Knoxville
 Email: jecates at utk.edu
 Phone: (865) 974-0694
 URL:   www.cs.utk.edu/~cates
--+--+--+--+--+--+--+--+--+--+--+---

On Mon, 17 Apr 2000, Will Schroeder wrote:

> Hi Folks-
> 
> GE & Kitware met for an architecture design review on Friday. If
> you're interested in some of the topics, there are PowerPoint slides
> in Insight/Documents/DesignReview (you'll want to do a "cvs update
> -d"). Look for DRApril2000.ppt.
> 
> Some of the questions we left the meeting with were:
> 
> * For some of you C++ hackers out there, can you tell us if (and how)
> there is a way to create templated filters that enforce as input an
> image of a certain dimension? (The itkImage class is currently
> templated over type and dimension. The filters are templated over
> input and output (the input & outputs are presumed to be a type of
> image - but dimension is not enforced.) Can it be done using some
> trait mechanism?
> 
> * Naming conventions: STL and many other packages use a naming
> convention with lowercase/underscore (get_the_variable). Since we are
> likely to use STL heavily (and maybe make the itkImage class STL
> compatible!?) this will result in a mix of naming conventions (Insight
> currently uses mixed Upper/Lowercase). Questions:
> 	- do we mix naming conventions? This has the advantage of
> indicating Insight code versus "external" code. However, if we add STL
> interface into the Insight classes, then we have the uncomfortable
> situation of having mixed naming conventions in the same class. (I
> suppose that we could get around this by introducing specific STL
> subclasses.)
> 	- do we adopt STL naming conventions?
> 
> Comments / questions / etc. are welcome.
> 
> Will
> 





More information about the Insight-developers mailing list