[IGSTK-Users] igstkImageSpatialObject memory management problem

Torleif Sandnes Torleif.Sandnes at sintef.no
Fri Jun 22 03:12:19 EDT 2007

Hi again.
Thanks for looking into this!

> When I run the tests, I don't encounter the error that you reported.
> so I'm wondering if something platform specific is going on here...

I compiled the sourcefiles I got from you, and ran the tests. The  
error was present on my local MR dataset  /Users/tosa/svn/CustusXdata/ 
Nevro/MRT1, but no error was *reported* on the MR dataset /IGSTK/ 
Testing/Data/Input/E000192, but it fails silently before the image is  
loaded. (Try adding a std::cout line in VolumeManager.cpp:92)

I also tried loading the IGSTK dataset IGSTK/Testing/Data/Input/ 
MRLiver. This failed in the way I described earlier. Maybe you could  
try to load this dataset to see if it works at your computer?

I am using gcc-4.0.1 on MacOsX 10.4.10.
itk version 3.0.1
vtk cvs checkout from april/may
igstk sandbox checkout from mars/april.

I should probably bring itk and igstk versions up to date, but I  
don't know if that really is the problem.


More information about the IGSTK-Users mailing list