[IGSTK-Developers] Tracker::SetReferenceTool method

David Gobbi dgobbi at atamai.com
Tue May 15 16:12:07 EDT 2007


Hi Ziv,

Breaking the method into two is a good idea.  This should also 
eventually become a "Request" method and should drive the state machine.

 - David


Ziv Yaniv wrote:
> Hi all,
>
> Just wanted to get everyones agreement to the following change in IGSTK:
>
> The method
> void Tracker::SetReferenceTool( bool applyReferenceTool,
>                                 unsigned int portNumber,
>                                 unsigned int toolNumber )
>
> receives as a first argument a boolean that says if we are or aren't 
> using a reference. This doesn't make much sense as the method requires 
> a port and tool too.
>
> I'd like to break the method into two methods,
>
> - don't use a reference:
> void Tracker::RemoveReferenceTool ()
>
> -use a reference:
> void Tracker::SetReferenceTool (unsigned int portNumber,
>                                 unsigned int toolNumber)
>
>                        regards
>                            Ziv
>




More information about the IGSTK-Developers mailing list