[CMake] add_library(... MODULE ...) naming scheme

Eric Noulard eric.noulard at gmail.com
Mon Jan 30 17:09:39 EST 2012


2012/1/30 Russell L. Carter <rcarter at esturion.net>:
>
> Greetings,
>
> I see from the docs that using add_library to build a MODULE results
> in the module being named according to the "conventions of the native
> platform (such as lib<name>.a or <name>.lib)".  And indeed MODULE
> names are so generated, as I see from actually building one.
>
> I would like to get rid of the "lib" prefix.  I am happy with the
> default suffix generation.  Is there an easy way to get rid of the
> "lib" prefix?
>
> A pointer to the place where the relevant variable or property or
> whatever is documented would be great, source code file is just
> fine, if that's all there is.

cmake --help-property PREFIX
cmake --help-variable CMAKE_SHARED_LIBRARY_PREFIX

for easy finding out about "prefix"
cmake --help-property-list | grep -i prefix
cmake --help-variable-list | grep  -i prefix


-- 
Erk
Membre de l'April - « promouvoir et défendre le logiciel libre » -
http://www.april.org


More information about the CMake mailing list