[CMake] Visual Studio 10 property pages for single source file gone with CMake 2.8.5 and 2.8.6

J Decker d3ck0r at gmail.com
Thu Nov 10 10:43:44 EST 2011

On Thu, Nov 10, 2011 at 7:14 AM, Niels Dekker - address until 2014
<niels_dekker_address_until_2014 at xs4all.nl> wrote:
> When Visual Studio 10 vcxproj files are generated by CMake 2.8.5 or 2.8.6,
> it is typically impossible to view the C/C++ properties of a single source
> file. CMake 2.8.0 to 2.8.4 do not seem to have this issue. It looks like the
> issue is caused by the fact that CMake 2.8.5 started storing the absolute
> path names of the source files (even when CMAKE_USE_RELATIVE_PATHS is ON).
> Is that a known issue?
> Visual Studio 10 does not allow viewing the C/C++ properties of source files
> that are listed by their absolute path names. See VS10 bug report 635294,
> "Using absolute path in ClCompile item prevents property pages from
> showing", by Niels M Hansen, 1/9/2011:
> https://connect.microsoft.com/VisualStudio/feedback/details/635294/using-absolute-path-in-clcompile-item-prevents-property-pages-from-showing
> However, it seems like Visual Studio 10 *does* correctly support absolute
> path names *without* drive letter! Would it be possible for CMake to write
> the source file names *without* the drive letter, when it generates Visual
> Studio 10 vcxproj files? (Especially when the generated vcxproj files are
> located at the same drive as the source files.)

I ran into this last night; but it wasn't all source files, just the
ones I had copied.  I even tried moving them into directories without
strange characters, and even back to the same source drive, but still
couldn't get the property pages.   But only on the souce files that
were .cpp the originals were .c and worked fine.  (A large portion of
sources I copy from .c to .cpp so I can build as both C and C++
seperately).  All of the .cpp files would not let me bring up
properties.  I manually copied one of the files and added that to the
++ project, and was able to bring up properties.  I was unable to
track down what exactly the problem was with the other sources.  They
were exactly like the .cpp that I had manually copied but they would
not allow me to open property pages.  This is 2.8.6-rc2.

> Kind regards,
>  Niels
> --
> Niels Dekker
> http://www.xs4all.nl/~nd/dekkerware
> Scientific programmer at LKEB, Leiden University Medical Center
> --
> Powered by www.kitware.com
> Visit other Kitware open-source projects at
> http://www.kitware.com/opensource/opensource.html
> Please keep messages on-topic and check the CMake FAQ at:
> http://www.cmake.org/Wiki/CMake_FAQ
> Follow this link to subscribe/unsubscribe:
> http://www.cmake.org/mailman/listinfo/cmake

More information about the CMake mailing list