[CDash] Drop method problem

Biddiscombe, John A. biddisco at cscs.ch
Tue Apr 14 15:23:47 UTC 2020

Might be better to post this to the cmake list, but ...

when I run a cmake configure step as part of a script I get

Output is
   Site: pop-os-jb
   Build name: 1-libfabric-D-LF
Submit files (using )
   Send to track: Pull_Requests
   Using FTP submit method
   Drop site: ftp://
But when I run it by hand I get
   Site: pop-os-jb
   Build name: 1-libfabric-D-LF
Submit files
   Send to group: Pull_Requests
   SubmitURL: https://cdash.cscs.ch/submit.php?project=GHEX
   Uploaded: /home/biddisco/pycicle/build/ghex-1-gcc-9-D-LF/Testing/20200414-1509/Update.xml
   Uploaded: /home/biddisco/pycicle/build/ghex-1-gcc-9-D-LF/Testing/20200414-1509/Configure.xml
   Uploaded: /home/biddisco/pycicle/build/ghex-1-gcc-9-D-LF/Testing/20200414-1509/Build.xml
   Uploaded: /home/biddisco/pycicle/build/ghex-1-gcc-9-D-LF/Testing/20200414-1509/Test.xml
   Uploaded: /home/biddisco/pycicle/build/ghex-1-gcc-9-D-LF/Testing/20200414-1509/Done.xml
   Submission successful

The CTestConfig.cmake contains

set(CTEST_DROP_METHOD "https")
set(CTEST_DROP_SITE "cdash.cscs.ch")
set(CTEST_DROP_LOCATION "/submit.php?project=GHEX")
and it generates a DartConfiguration.tcl file in the build dir that looks correct in script mode, or by hand.

I notice in the docs that DartConfiguration.tcl isn't the name listed and CTestConfiguration.tcl is the preferred one. I suspect that I have something 'old' or out of date in my config. Can anyone guess what might be wrong?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/cdash/attachments/20200414/a6fefb36/attachment.htm>

More information about the CDash mailing list