[Cdash] missing field emailcommitters

Yngve Inntjore Levinsen yngve.levinsen at gmail.com
Fri Oct 18 12:43:26 UTC 2013

Den 17. okt. 2013 13:49, skrev Igor Murzov:
> On Wed, 16 Oct 2013 20:54:45 +0200
> Yngve Inntjore Levinsen <yngve.levinsen at gmail.com> wrote:
>> Den 16. okt. 2013 11:47, skrev Igor Murzov:
>>> On Wed, 16 Oct 2013 09:30:38 +0200
>>> Yngve Inntjore Levinsen <yngve.levinsen at gmail.com> wrote:
>>>> In my cdash log I have a lot of warnings like this:
>>>> [2013-10-16T09:02:44][INFO][pid=22094](pdo_single_row_query):
>>>> error: pdo_query failed: Unknown column 'emailcommitters' in
>>>> 'field list' I use cdash version 2.0.2, I upgraded a while back
>>>> from 1.8.something I think it was, so maybe that is why I don't
>>>> have this field in the table.
>>> You're right, you need to upgrade your database after CDash upgrade.
>>> Log in to your CDash as administrator, Switch to 'My CDash' view.
>>> Find 'Maintenance' link in the bottom of the page. On the
>>> maintenance page there is a 'Upgrade CDash' button. Push it and
>>> wait for a while. This should fix your issue.
>> Thanks for the quick reply. I thought I already upgraded the database,
>> but I did again now. That resulted in the following output in the log:
>> [2013-10-16T13:39:01][INFO][pid=11646](AddTablePrimaryKey): Adding
>> primarykey id to buildupdate
>> [2013-10-16T13:39:01][INFO][pid=11646](AddTablePrimaryKey): Done
>> adding primarykey id to buildupdate
>> [2013-10-16T13:39:01][INFO][pid=11646](ModifyTableField): Modifying
>> id to buildupdate
>> [2013-10-16T13:39:01][INFO][pid=11646](ModifyTableField): Done
>> modifying id to buildupdate
>> [2013-10-16T13:39:01][INFO][pid=11646](upgrade-2-1): Upgrade done.
>> However, I am still getting the error messages in my log (seems to be
>> triggered by new builds coming in), and the emailcommitters column is
>> still not in the buildgroup table.
> Looks like you somehow skipped upgrade to CDash-2.0 and did upgrade to
> CDash-2.1 instead. What is your 'Current CDash database schema'
> version?
> -- Igor

Under "My CDash" -> "Maintenance", it states "Current CDash database

It could be that perhaps I tried directly to jump to 2.1, then moved
back to 2.0 after it failed. This is not something I remember, but I can
see that it might have happened. For what it's worth, the web page can
be found here:


More information about the CDash mailing list