[Cdash] Fwd: [CMake] problems upgrading cdash

Yngve Levinsen yngve.levinsen at gmail.com
Tue Nov 20 15:10:11 UTC 2012

Sorry, forgot to include the mailing list in cc.

---------- Forwarded message ----------
From: Yngve Levinsen <yngve.levinsen at gmail.com>
Date: 20 November 2012 16:09
Subject: Re: [Cdash] [CMake] problems upgrading cdash
To: Julien Jomier <julien.jomier at kitware.com>

Thanks for your suggestions and offer to help. I tried both with Firefox
and Google Chrome, and then finally I also tried on a Windows Virtual
Machine I have available. No success. When I click the button it returns
with the information about "already updated" very quickly, so it does not
look like it is doing anything.

The instance is now running of a copied database, so that I am sure not to
corrupt the old instance of CDash. I also gave you an account with admin
privileges, you should have gotten an e-mail about it. And finally of
course as suggested on the wiki for cdash upgrades, I have a dump of the
entire database on file just in case.


On 20 November 2012 12:21, Julien Jomier <julien.jomier at kitware.com> wrote:

> Yngve,
> It might be an issue with the javascript during the upgrade. Can you try
> with a different browser?
> Otherwise, would it be possible to give me administrative privileges on
> this instance of CDash so I can try to upgrade and check.
> Julien
> On 19/11/2012 15:50, David Cole wrote:
>> There's a separate mailing list for CDash questions. I've forwarded your
>> mail to cdash at public.kitware.com <mailto:cdash at public.kitware.**com<cdash at public.kitware.com>
>> >
>> On Mon, Nov 19, 2012 at 7:54 AM, Yngve Levinsen
>> <yngve.levinsen at gmail.com <mailto:yngve.levinsen at gmail.**com<yngve.levinsen at gmail.com>>>
>> wrote:
>>     Dear CMakers,
>>     I tried just now to upgrade my cdash server from 1.8.2 to 2.0.2. I
>>     get an error "SQL error in Project::GetUploadsTotalSize()**:Table
>>     'cdash.build2uploadfile' doesn't exist"
>>     I also see a message "The current database shema doesn't match the
>>     version of CDash you are running, upgrade your database structure in
>>     the Administration/CDash maintenance panel of CDash". If I click on
>>     the "Upgrade CDash" button, it says that my database is already up
>>     to date.
>>     Could someone point out what I (might) have forgotten? You can see
>>     both installations here:
>>     http://cern.ch/yngve/CDash-2.**0.2/<http://cern.ch/yngve/CDash-2.0.2/>
>>     http://cern.ch/yngve/CDash-1.**8.2/<http://cern.ch/yngve/CDash-1.8.2/>
>>     (I guess inn principle the old version should not work anymore if
>>     the upgrade had been successful..)
>>     Best Regards,
>>     Yngve
>>     --
>>     Powered by www.kitware.com <http://www.kitware.com>
>>     Visit other Kitware open-source projects at
>>     http://www.kitware.com/**opensource/opensource.html<http://www.kitware.com/opensource/opensource.html>
>>     Please keep messages on-topic and check the CMake FAQ at:
>>     http://www.cmake.org/Wiki/**CMake_FAQ<http://www.cmake.org/Wiki/CMake_FAQ>
>>     Follow this link to subscribe/unsubscribe:
>>     http://www.cmake.org/mailman/**listinfo/cmake<http://www.cmake.org/mailman/listinfo/cmake>
>> ______________________________**_________________
>> Cdash mailing list
>> Cdash at public.kitware.com
>> http://public.kitware.com/cgi-**bin/mailman/listinfo/cdash<http://public.kitware.com/cgi-bin/mailman/listinfo/cdash>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/cdash/attachments/20121120/f6832f0f/attachment-0003.htm>

More information about the CDash mailing list