[Cdash] about submission of big test, coverage reports

girish hilage girish_hilage at yahoo.com
Fri Jan 28 13:59:53 UTC 2011

Thanks for the response.
I will try upgrading both ctest and cdash.
However, I would like to inform that it is working for me with current versions.

The behaviour I observed is as follows :

when I changed permissions of 'backup/' directory to "700" then :
Test report gets submitted only if there are few test cases (I tried with 1 testcase)
Coverage report does not get submitted.

when I changed permissions of 'backup/' directory to "777" then :
Test report with lot of testcases gets submitted
Coverage report also gets submitted.

Not sure if permissions of 'backup/' play any role during report submission.


--- On Fri, 1/28/11, David Cole <david.cole at kitware.com> wrote:

From: David Cole <david.cole at kitware.com>
Subject: Re: [Cdash] about submission of big test, coverage reports
To: "girish hilage" <girish_hilage at yahoo.com>
Cc: cdash at public.kitware.com
Date: Friday, January 28, 2011, 10:58 AM

Update ctest to 2.8.3 or 2.8.4-rc1 and try again. There were some issues with earlier versions ignoring error returns from CDash.

You may see "submission errors" reported with a newer ctest.

There were also some corresponding changes made on the CDash side since 1.6.4 that may be applicable.

Test output compression was also added since the versions you are reporting here.

If you have very large output from tests and coverage data, you may need to increase the php memory limits for your CDash installation, too. We typically set the php memory limit to something over 100M for the projects hosted on cdash.org.

First try upgrading just ctest to see if you get more information back at submission time. Then, the php memory settings. Then, try upgrading CDash as well if you can.


On Fri, Jan 28, 2011 at 12:42 AM, girish hilage <girish_hilage at yahoo.com> wrote:


   This is to ask about the size of the Coverage, Test report that is submitted to CDASH.

   I am using ctest to compile and test my project and submit the report to CDASH.
   The issue is that, it is not submitting test and coverage reports to CDASH, eventhough the output of ctest shows Test.xml, CoverageLog-*.xml files getting successfully submitted. When I access dashboard through Firefox I see test, coverage columns as blank.

   I even checked into mysql database and it shows no data in tables (test, coverage).

   There are lot of tests that I am executing.
   If I try executing only 1 test then in that case I can see the test report in the dashboard (coverage report is still not visible).

   So, could this be due to any limitation on the size of the data being submitted to CDASH?

   CDASH version I am using is 1.6.4, and ctest version is 2.8.0


Cdash mailing list
Cdash at public.kitware.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/cdash/attachments/20110128/d43bc14c/attachment-0003.htm>

More information about the CDash mailing list