[vtkusers] renaming transform classes

David Gobbi dgobbi at irus.rri.on.ca
Mon Jun 5 11:15:37 EDT 2000


Hi All,

People using the vtk 3.1 release or an earlier release can safely ignore
this message.

I'm planning to rename some of the vtk*Transform classes that I've added
to VTK over the last few months.  I will leave stand-in classes with the
old names around so that everyone's code will still work, but if you use
a class by its old name it will print a warning.

The good old vtkTransform class will remain the same, of course.  This 
change will only impact the people who use vtkProjectionTransform or 
vtkGeneralTransformConcatenation or certain other weird, new
transforms.  

I'm not doing this just to be ornery!  I really think that, because of
the way I've changed things recently, the old names would be confusing
to people.  


Here is the new naming scheme:

Abstract Transform Types
~~~~~~~~~~~~~~~~~~~~~~~~
vtkAbstractTransform   - any geometrical transformation
          |
vtkHomogenousTransform - any transformation representable as a 4x4 matrix
          |
vtkLinearTransform     - any linear transformation


Concrete Transform Types
~~~~~~~~~~~~~~~~~~~~~~~~
vtkTransform            - you should be familiar with this one

vtkPerspectiveTransform - like vtkTransform, but it can represent
                          perspective transformations as well

vtkGeneralTransform     - like vtkTransform, but it can represent
                          any transform type

All of these concrete transform types support the same basic set of
methods: Translate(), RotateWXYZ(), Scale(), Concatenate(), SetInput(),
etc.  


Here are the details of how the renaming will be done:

new                        old

vtkAbstractTransform    <- vtkGeneralTransform
vtkHomogenousTransform  <- vtkPerspectiveTransform
vtkLinearTransform      unchanged
vtkIdentityTransform    unchanged

vtkGeneralTransform     <- vtkGeneralTransformConcatenation
vtkPerspectiveTransform <- vtkProjectionTransform
vtkTransform            unchanged

vtkMatrixToHomogenousTransform  <-  vtkMatrixToPerspectiveTransform
vtkMatrixToLinearTransform      unchanged

vtkWarpTransform        unchanged
vtkGridTransform        unchanged
vtkThinPlateSplineTransform  unchanged


Note that there will be no vtkGeneralTransformConcatenation or similarly
named classes anymore.  Those names weren't exactly popular.

 - David

--
  David Gobbi, MSc                    dgobbi at irus.rri.on.ca
  Advanced Imaging Research Group
  Robarts Research Institute, University of Western Ontario





More information about the vtkusers mailing list