Hi Bill,<div><br></div><div>Are you planning to bring in some type of Unit Testing into VTK? </div><div><br></div><div>Currently each tests in VTK tests a bunch of different classes spread across different modules. An obvious disadvantage is that some parts of the code keeps getting tested multiple times which is sort of pointless (in terms of testing). With unit testing one could just focus on one class at at time. </div>
<div><br></div><div>Also a unit testing approach may be good for focused coverage where one is focused on improving coverage on a limited set of classes.</div><div><br></div><div>There are many unit test frameworks out there. CppUnit seem to a good one. </div>
<div><br></div><div>-Nikihl</div><div><br><div class="gmail_quote">On Tue, Sep 18, 2012 at 5:43 PM, Bill Lorensen <span dir="ltr"><<a href="mailto:bill.lorensen@gmail.com" target="_blank">bill.lorensen@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">My main concern is that vtk coverage is very low, and unacceptable.<div><br></div><div>I would rather spend time on improving the coverage. If others want to improve the process, that is great. Past experience shows that too much time is spent on testing process and too little on actual testing.</div>
<div><br></div><div>I say go for it, but I will concentrate in test coverage.</div><div><br></div><div>Bill</div><div><br></div><div><div><div><br><div class="gmail_quote">On Tue, Sep 18, 2012 at 5:34 PM, David Doria <span dir="ltr"><<a href="mailto:daviddoria@gmail.com" target="_blank">daviddoria@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div>On Tue, Sep 18, 2012 at 4:23 PM, Bill Lorensen <<a href="mailto:bill.lorensen@gmail.com" target="_blank">bill.lorensen@gmail.com</a>> wrote:<br>
> Folks,<br>
><br>
> I mentioned earlier that my Fall/Winter VTK project is improving code<br>
> coverage.<br>
><br>
> I'm starting with some low hanging fruit, namely Common/Core which has 19<br>
> files flagged by cdash as low coverage:<br>
> <a href="http://open.cdash.org/viewCoverage.php?buildid=2568829" target="_blank">http://open.cdash.org/viewCoverage.php?buildid=2568829</a><br>
><br>
> For example I just pushed this topic to gerrit that addresses testing for<br>
> vtkTimePointUtilities, a class that has 0 coverage. I'm pretty sure there<br>
> are bugs in this code, mainly surrounding boundary conditions that would not<br>
> affect its usage, whatever that may be.<br>
> <a href="http://review.source.kitware.com/#/t/1295/" target="_blank">http://review.source.kitware.com/#/t/1295/</a><br>
><br>
> But rather than rant, I'll ask the community to review the gerrit topics.<br>
><br>
> Bill<br>
<br>
</div></div>This sounds like a great project.<br>
<br>
If you are going to be adding tons of tests, can we discuss a<br>
standardized format for them? The current method of putting everything<br>
in Test[TestName]() seems very error prone (accidental use of<br>
previously defined variables, name clashes, etc) and is definitely<br>
hard to read. I have pushed a new patch set that breaks some things<br>
out into functions. Is there any problem with doing it like this? It<br>
seems much more readable to me. In this case these functions are all<br>
void (because the content doesn't get checked for failure anyway), but<br>
of course they could return 'int' so that 'return EXIT_SUCCESS' could<br>
be ANDed with the other tests to produce the final test return value.<br>
<br>
Thoughts?<br>
<span><font color="#888888"><br>
David<br>
</font></span></blockquote></div><br><br clear="all"><div><br></div></div></div><span><font color="#888888">-- <br>Unpaid intern in BillsBasement at noware dot com<br><br>
</font></span></div>
<br>_______________________________________________<br>
Powered by <a href="http://www.kitware.com" target="_blank">www.kitware.com</a><br>
<br>
Visit other Kitware open-source projects at <a href="http://www.kitware.com/opensource/opensource.html" target="_blank">http://www.kitware.com/opensource/opensource.html</a><br>
<br>
Follow this link to subscribe/unsubscribe:<br>
<a href="http://www.vtk.org/mailman/listinfo/vtk-developers" target="_blank">http://www.vtk.org/mailman/listinfo/vtk-developers</a><br>
<br>
<br></blockquote></div><br></div>