<div class="gmail_quote">On Wed, Jun 16, 2010 at 2:31 PM, David Gobbi <span dir="ltr"><<a href="mailto:david.gobbi@gmail.com">david.gobbi@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

On Wed, Jun 16, 2010 at 11:14 AM, Marcus D. Hanwell<br>
<div class="im"><<a href="mailto:marcus.hanwell@kitware.com">marcus.hanwell@kitware.com</a>> wrote:<br>
><br>
</div><div class="im">> Just to confirm that this was committed to VTK master earlier today, I fixed<br>
> one issue in vtkTextAnalysis and so far the dashboards are looking pretty<br>
> good. Please let us know if you encounter any problems.<br>
> Thanks,<br>
> Marcus<br>
<br>
</div>I have to give a big thanks to Marcus and Keith for merging this, and<br>
to anyone else at Kitware who was involved.  You can bet that I fully<br>
appreciate all the time that was put into testing the code, plus all<br>
the work that went into rebasing my commits to the current VTK master<br>
(something you must have had to do at least two or three times).<br></blockquote><div><br></div><div>I appreciate all the time you have put into fixing up the issues we found, and am very pleased we could get this in. Some of my work was being impeded by restrictions in the bindings generators, and with these improvements much more of our C++ API can be wrapped, and I can stop writing duplicate functions for the wrapped languages.</div>

<div><br></div><div>I would like to thank the community for holding off on pushing stuff into VTK master. Please feel free to resume development as normal. There are a few issues we need to work through, some new failures on the nightly submissions. </div>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<br>
This merge adds the following to VTK:<br>
<br>
1) Proper vtkStdString support for all wrappers, it used to sort-of<br>
work but was mostly broken.  By "all wrappers", I mean Tcl, Java,<br>
Python, and ParaView's VTKClientServer.<br>
<br>
2) Support for vtkUnicodeString and vtkVariant within the python<br>
wrappers, with the potential of supporting scores of other currently<br>
unwrapped classes in the coming weeks.<br>
<br>
3) A major clean-up of the lex/yacc front-end for the wrappers, it<br>
understands much more C++ now.<br></blockquote><div><br></div><div>You forgot the much improved readability of the wrapping code too. A lot of work has gone into refactoring some of the code, and removing some of the old unused code. </div>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<br>
The main thing that I hope this merge will bring is a solid foundation<br>
for moving the wrappers forward.  Lately too much of VTK has become<br>
accessible only from C++.<br></blockquote><div><br></div><div>Agreed (or we have been forced to write redundant API to help wrapped languages). </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">


<br>
For any interested parties, I wrote a disorganized wiki page about the<br>
changes to the wrapper code:<br>
<a href="http://www.vtk.org/Wiki/index.php?title=VTK/Wrapping_Special_Types" target="_blank">http://www.vtk.org/Wiki/index.php?title=VTK/Wrapping_Special_Types</a><br>
<br>
Specifically for Python, I have updated README_WRAP.txt:<br>
<a href="http://vtk.org/gitweb?p=VTK.git;a=blob;f=Wrapping/Python/README_WRAP.txt" target="_blank">http://vtk.org/gitweb?p=VTK.git;a=blob;f=Wrapping/Python/README_WRAP.txt</a><br>
<br></blockquote><div>The wrapping in VTK is now much clearer to me. I might even take a stab at fixing some stuff up myself as and when necessary. I have a few other minor improvements in mind such as removing the hard coded lib prefix for Python modules on POSIX systems, making the wrapping more flexible around class names for other projects such as Titan that are using the VTK wrapping code.</div>

<div><br></div><div>Thanks,</div><div><br></div><div>Marcus</div><div>--</div><div>Marcus D. Hanwell, Ph.D.<br>R&D Engineer, Kitware Inc.<br>(518) 881-4937<br></div></div>