<HTML>
<HEAD>
<TITLE>Re: [vtk-developers] Rename vtkBoostBreadthFirstSearch?</TITLE>
</HEAD>
<BODY>
<FONT FACE="Calibri, Verdana, Helvetica, Arial"><SPAN STYLE='font-size:11pt'>Generally speaking, I believe the naming convention on the VTK filters that use BGL algorithms has been to name the filter after the BGL algorithm that it’s calling. Since vtkBoostBreadthFirstSearch relies on the BGL breadth-first search algorithm we use that name.<BR>
<BR>
In the current form it only executes a BFS with a specific visitor class that just records the distance from the root. Perhaps rather than renaming the class to match the default behavior, we should think about changes that allow the visitor class to be customized? The default behavior should probably remain the same though...<BR>
<BR>
-William<BR>
<BR>
<BR>
<BR>
On 3/29/10 2:58 PM, "Moreland, Kenneth" <<a href="kmorel@sandia.gov">kmorel@sandia.gov</a>> wrote:<BR>
<BR>
</SPAN></FONT><BLOCKQUOTE><FONT FACE="Calibri, Verdana, Helvetica, Arial"><SPAN STYLE='font-size:11pt'>If the filter relies on Boost, then it should have Boost in the name (i.e. vtkBoostGraphDistanceFilter). I don’t use these filters much so beyond that I am pretty agnostic.<BR>
<BR>
-Ken<BR>
<BR>
<BR>
On 3/28/10 12:23 PM, "David Doria" <<a href="daviddoria+vtk@gmail.com">daviddoria+vtk@gmail.com</a>> wrote:<BR>
<BR>
</SPAN></FONT><BLOCKQUOTE><FONT FACE="Calibri, Verdana, Helvetica, Arial"><SPAN STYLE='font-size:11pt'>It looks like the only function of vtkBoostBreadthFirstSearch is to compute the distance from every vertex to the origin vertex and append a vtkIntArray to the input graph containing these values. If that is correct, the name of the class seems very confusing to me. Could it be changed to something more like vtkGraphDistanceFilter or something like that?<BR>
<BR>
Thanks,<BR>
<BR>
David<BR>
<BR>
</SPAN></FONT></BLOCKQUOTE><FONT FACE="Calibri, Verdana, Helvetica, Arial"><SPAN STYLE='font-size:11pt'><BR>
</SPAN></FONT><FONT SIZE="2"><FONT FACE="Consolas, Courier New, Courier"><SPAN STYLE='font-size:10pt'><BR>
**** Kenneth Moreland<BR>
*** Sandia National Laboratories<BR>
*********** <BR>
*** *** *** email: <a href="kmorel@sandia.gov">kmorel@sandia.gov</a><BR>
** *** ** phone: (505) 844-8919<BR>
*** web: <a href="http://www.cs.unm.edu/~kmorel">http://www.cs.unm.edu/~kmorel</a><BR>
</SPAN></FONT></FONT></BLOCKQUOTE><FONT FACE="Calibri, Verdana, Helvetica, Arial"><SPAN STYLE='font-size:11pt'><BR>
</SPAN></FONT>
</BODY>
</HTML>