[Insight-developers] Re: Proposal: Change default DICOM fromDICOMImageIO2 to GDCMImageIO

Miller, James V (Research) millerjv at crd.ge.com
Tue Apr 19 08:52:01 EDT 2005


I think there must be another way to structure this.

None of the other *SeriesFilenames generators need two directories.

Perhaps once a set of filenames has been generated using GDCMSeriesFileNames, 
a call to SetDirectory() would then change the "Directory" prefix 
on each of the filenames that it already generated.

I just don't think we need a SetInputDirectory and SetOutputDirectory
since none of the other generators need two methods.

Jim


-----Original Message-----
From: Mathieu Malaterre [mailto:mathieu.malaterre at kitware.com]
Sent: Monday, April 18, 2005 4:50 PM
To: Miller, James V (Research)
Cc: Insight Developers
Subject: Re: [Insight-developers] Re: Proposal: Change default DICOM
fromDICOMImageIO2 to GDCMImageIO


Jim,

	I am not sure I understand this. GDCMSeriesFileNames first goal is 
really to order a series of dicom files. Let say the proper ordering is:

AA.dcm, CC.dcm, BB.dcm (*)

	Now user would set the input directory, then retrieve the ordered files 
(GDCMSeriesFileNames::GetInputFileNames()), then to preserve the 
filename convention would set output directory, and GDCMSeriesFileName 
would write in this directory using the same 'file-'naming convention.

	In your solution how do you differenciate the input directory from the 
output directory ?

Mathieu
(*) This correspond to the case where the filenames are the UID and 
therefore alphabetical ordering is different from the real ordering.

Miller, James V (Research) wrote:
> Keep in mind that under most circumstances, we would NOT use the 
> same instance of GDCMImageIO to read files and to write files. 
> Under this model, wouldn't a single "SetDirectory" call be
> sufficient?
> 
> Jim
> 
> 
> -----Original Message-----
> From: insight-developers-bounces at itk.org
> [mailto:insight-developers-bounces at itk.org]On Behalf Of Mathieu
> Malaterre
> Sent: Monday, April 18, 2005 1:31 PM
> To: Lorensen, William E (Research)
> Cc: Insight Developers
> Subject: [Insight-developers] Re: Proposal: Change default DICOM
> fromDICOMImageIO2 to GDCMImageIO
> 
> 
> Lorensen, William E (Research) wrote:
> 
>>Folks,
>>I'd like to start a discussion about making GDCM the default DICOM reader/writer in itk. Please add your comments to:
>>http://www.itk.org/Wiki/Proposals:Make_GDCM_the_default_DICOM
> 
> 
> No sure if this is usefull to add to the wiki:
> 
> 1. DICOMSeriesFilenames
> 
> There is a lot of work to do. Keep in mind that those class were written 
> against gdcm 0.5 which had lot less advanced features. Anyway to enhance 
> the class I would also suggest it can have multiple choices of 
> generating names:
> 
> a) Keep the original name, but then we have to write files in another 
> directory  (thus we need an 'input' dir and an 'output' dir).
> 
> b) Since DICOM does not specify the naming convention for the filename, 
> we should be able to write the file under its UID (it's garantee to be 
> unique!).
> 
> c) Another approach (more conventional) would be to specify a prefix and 
> a pattern. (we don't require two differents directories anymore).
> 
> 
> 
> 
> 2. DICOMSeriesFilenames
> 
> gdcm 0.6 could only handle one serie within a directory. gdcm 1.0 and 
> above have a much easier API to manipulate multiple series (and order 
> files) within the same directory. For more info see gdcm::SerieHelper
> 
> 
> 
> Mathieu
> _______________________________________________
> Insight-developers mailing list
> Insight-developers at itk.org
> http://www.itk.org/mailman/listinfo/insight-developers
> 



More information about the Insight-developers mailing list