[Insight-developers] Array vs FixedArray

Luis Ibanez luis.ibanez@kitware.com
Mon, 12 May 2003 20:09:07 -0400


Hi Mark,

I agree with you in that the methods should be made consistent.
The methods that the itk::Array inherits from the vnl_vector
should be wrapped in methods with ITK naming conventions.


Unfortunately this will result in a performance hit when compiling
in Debug mode since the code of the wrapped methods will not be
inlined.  This should be ok when compiling with optimization.


One of the ITK sectors were the itk::Array is heavily used is in
the Registration Framework.  The parameters of the transforms are
passed around in itk::Arrays. Note however that Lydia proposed a
reorganization of the parameter passing since it is not well
adapted for transforms with large number of parameters
(e.g. like deformable transforms based on BSplines).

So, this may be a good oportunity to make both changes.



   Luis




---------------------
Mark Foskey wrote:
> I see that the corresponding methods are there, they just have 
> lower-case names and don't show up in the Doxygen docs.  But still, it's 
> not consistent.
> 
> Mark Foskey wrote:
> 
>> I noticed that the FixedArray type has a much more extensive list of 
>> methods (e.g., Begin() and End()) than the Array type.  Wouldn't it be 
>> good if the two were consistent?  I realize that one inherits from vnl 
>> while the other doesn't, but should that matter?
>>
> 
>