[CMake] Binary packages naming convention

Eric Noulard eric.noulard at gmail.com
Wed Jun 8 05:53:01 EDT 2011


2011/6/7 Jean-Christophe Fillion-Robin <jchris.fillionr at kitware.com>:
> Hi Folks,
>
> I observed there are different ways of naming binary packages:
>
>    myproject-Linux-i386.{ext}
>    myproject-Linux-amd64.{ext}
>    myproject-Linux-x86_32.{ext}
>    myproject-Linux-x86_64.{ext}
>
>    myproject-Windows-win32_x86.{ext}
>    myproject-Windows-win64_x86.{ext}
>    myproject-Windows-win64_x64.{ext}
>    myproject-Windows-x86_32.{ext}
>    myproject-Windows-x86_64.{ext}
>
>    myproject-Darwin-amd64.{ext}
>
>    ...
>
> Was wondering which naming scheme should I favor ?
>
> I am thinking to use:
>    myproject-Linux-i386.{ext}
>    myproject-Linux-amd64.{ext}
>    myproject-Windows-win32_x86.{ext}
>    myproject-Windows-win64_x86.{ext}
>    myproject-Darwin-amd64.{ext}
>
> If there any reason I shouldn't choose that convention ?

The naming convention may depends on:
   - the host system (Windows, MacOS, Linux, Soalris etc...)
   - the package format (RPM, DEB, Package Maker etc...)
   - in the Linux case the distribution convention
      Fedora and OpenSuSE are RPM-based but they do not necesseraly
use the same naming scheme.
      same problem with Debian / Ubuntu for DEB.

So I think the appropriate naming scheme could be enforced (or at
least suggested) by
the CPack generator, this is now possible since 2.8.3:
http://public.kitware.com/Bug/view.php?id=9900

And some bug are open for that:
http://public.kitware.com/Bug/view.php?id=11050

So at least on Linux I would suggest to try to do it at CPack level.
On the Windows side you may want to mangle the package name depending
on the name
of the compiler used. If your package includes devel. lib knowing that
it has been compiled
with MSVC or MinGW could be useful.
In the same way may be "Windows" is not enough and you would want
WinXP/WinVISTA.

I did write some preliminary CMake scripts in order to do such
specific system informations,
find it attached to the mail.


-- 
Erk
Membre de l'April - « promouvoir et défendre le logiciel libre » -
http://www.april.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: SystemSpecificInformations.cmake
Type: application/octet-stream
Size: 6771 bytes
Desc: not available
URL: <http://www.cmake.org/pipermail/cmake/attachments/20110608/0ba27785/attachment.obj>


More information about the CMake mailing list