[Cmake] can't build on aix

Silverstein herc at schrodinger . com
Thu, 17 Jan 2002 10:25:56 -0800

Brad King wrote:
> Herc,
> Thanks for your report.
> > I just downloaded cmake and tried to build on aix 4.3.3 with the visual
> > age 5.0 c++ compiler. But it fails to build.  I set CXX=/usr/bin/xlC.
> >
> > Is this code ANSI C++ compliant (not sure this is the issue but we have
> > had this issue with other stuff recently)?
> [snip]
> > "cmUnixMakefileGenerator.h", line 111.50: 1540-0040 (S) The text "&" is
> > unexpected.  "cmMakeDepend" may be undeclared or ambiguous.
> > make: The error code from the last command is 1.
> The code is intended to be standard compliant, with various work-arounds
> to support non-compliant compilers.  Your problem is a bug in the code,
> though, and it just happened that none of the compilers we use caught it.
> I just committed a fix to CVS.  If you are using the release version, try
> adding the line
> class cmMakeDepend;
> below the lines
> class cmFunctionBlocker;
> class cmCommand;
> class cmMakefileGenerator;
> in CMake/Source/cmMakefile.h
> Please let us know if it builds okay after that.  I don't believe we have
> ever tried using your compiler before.
> Thanks,
> -Brad

Thanks for the speedy reply.  Now it gets farther, but not all the way.

        /usr/bin/xlC -DCMAKE_ROOT_DIR='"/home/herc/surf/CMake-1-2"' -g
-DCMAKE_HAS_AUTOCONF -I/home/herc/surf/CMake-1-2/Source -c
cmCableClassSet.cxx -o cmCableClassSet.o
"cmCableClassSet.cxx", line 226.30: 1540-0300 (S) The "private" member
"class ElementCombinationGenerator::Portion" cannot be accessed.
make: 1254-004 The error code from the last command is 1.

The declaration in the header shows the inheritance as being public, but
for some reason it looks like the StringPortion class sees Portion as
private.  I tried making StringPortion and ElementCombinationGenerator
friends of Portion, but no luck...