View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0010935CMakeCPackpublic2010-07-04 11:072010-12-14 18:50
ReporterEric NOULARD 
Assigned ToEric NOULARD 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionCMake-2-8 
Target VersionFixed in VersionCMake-2-8 
Summary0010935: Lack of support for relocatable package
DescriptionI would like to add an other missing feature:
 * Lack of support for relocatable package

To make a relocatable package, you have to add a tag "Prefix: " whose the value is generally the CMake prefix.


If I mimic the Buildarch tag, it would be something like that

# CPACK_RPM_PACKAGE_PREFIX (optional)
IF(CPACK_RPM_PACKAGE_PREFIX)
  SET(TMP_RPM_PREFIX "Prefix: ${CPACK_RPM_PACKAGE_PREFIX}")
  IF(CPACK_RPM_PACKAGE_DEBUG)
    MESSAGE("CPackRPM:Debug: using user-specified prefix (for relocatable package) = ${CPACK_RPM_PACKAGE_PREFIX}")
  ENDIF(CPACK_RPM_PACKAGE_DEBUG)
ELSE(CPACK_RPM_PACKAGE_PREFIX)
  SET(TMP_RPM_BUILDARCH "")
ENDIF(CPACK_RPM_PACKAGE_PREFIX)


and adding \@TMP_RPM_PREFIX\@ after \@TMP_RPM_BUILDARCH\@ in the specfile template.

It's not tested but it's very similar to Buildarch tag.

For more specific information, see Maximum RPM (http://www.rpm.org/max-rpm/ch-rpm-reloc.html [^] [^] ).


Please, tell me if I must create a new issue but it's very similar to this one. Thanks.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
parent of 0007000closedEric NOULARD CPack RPM generator should always "CPACK_SET_DESTDIR" 
related to 0010701closedEric NOULARD Lack of "%doc, %config, Obsolete" in CPackRPM 

-  Notes
(0021232)
Eric NOULARD (developer)
2010-07-04 11:29

The line to add is easy.
Prefix: \@CPACK_PACKAGING_INSTALL_PREFIX\@


However it may be added iff there is no absolute path file installed
or the packaging will break.
(0021338)
Eric NOULARD (developer)
2010-07-09 14:06

This has been pushed to next.

To git@cmake.org:cmake.git
   35ab6ee..c8c3211 next -> next

Note we are still depending on bug 7000 in order to support relocatable
package with file installed using absolute path
(provided those are %config... but this is another story)
(0021339)
Eric NOULARD (developer)
2010-07-09 14:07

commit c8c32115c92be0f84a070c7e9cae99b78a0e20cf
Merge: 35ab6ee 604c369
Author: Eric NOULARD <eric.noulard@gmail.com>
Date: Fri Jul 9 20:04:38 2010 +0200

    Merge branch 'CPackRPM-RelocatablePackage' into next

commit 604c3698c1ba517b83b4e6142bf95f9562fed921
Author: Eric NOULARD <eric.noulard@gmail.com>
Date: Fri Jul 9 20:01:57 2010 +0200

    CPackRPM:: [partially] support relocatable package
    
    The support is partial because it cannot be used if
       CPACK_SET_DESTDIR is set
       some file are installed using absolute path
(0024103)
David Cole (manager)
2010-12-14 18:50

Closing bugs that have been resolved for more than 3 months without any further updates.

- Issue History
Date Modified Username Field Change
2010-07-04 11:07 Eric NOULARD New Issue
2010-07-04 11:08 Eric NOULARD Relationship added related to 0010701
2010-07-04 11:09 Eric NOULARD Status new => assigned
2010-07-04 11:09 Eric NOULARD Assigned To => Eric NOULARD
2010-07-04 11:29 Eric NOULARD Note Added: 0021232
2010-07-04 11:30 Eric NOULARD Relationship added parent of 0007000
2010-07-09 14:06 Eric NOULARD Note Added: 0021338
2010-07-09 14:07 Eric NOULARD Note Added: 0021339
2010-07-09 14:07 Eric NOULARD Status assigned => resolved
2010-07-09 14:07 Eric NOULARD Fixed in Version => CMake-2-8
2010-07-09 14:07 Eric NOULARD Resolution open => fixed
2010-12-14 18:50 David Cole Note Added: 0024103
2010-12-14 18:50 David Cole Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker